Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
courses:cs366:syllabus [2020/01/21 15:15]
ide
courses:cs366:syllabus [2020/01/21 17:28] (current)
ide
Line 7: Line 7:
  
 == Other useful books and materials == == Other useful books and materials ==
-  * Dickinson, Brew, and Meuers. [[https://​www.wiley.com/​en-us/​Language+and+Computers-p-9781405183055 | Language and Computers.]] Wiley Press. ​+  * Dickinson, Brew, and Meuers. [[https://​www.wiley.com/​en-us/​Language+and+Computers-p-9781405183055 | Language and Computers.]] Wiley Press.
   * Manning, C. and Schütze, H.  [[https://​nlp.stanford.edu/​fsnlp/​ | Foundations of Statistical Natural Language Processing.]] MIT Press.   * Manning, C. and Schütze, H.  [[https://​nlp.stanford.edu/​fsnlp/​ | Foundations of Statistical Natural Language Processing.]] MIT Press.
   * Witten, I. H., Eibe, F., Hall, M.A. [[https://​www.elsevier.com/​books/​data-mining/​witten/​978-0-12-804291-5 | Data Mining: Practical Machine Learning Tools and Techniques]],​ Fourth Edition.   * Witten, I. H., Eibe, F., Hall, M.A. [[https://​www.elsevier.com/​books/​data-mining/​witten/​978-0-12-804291-5 | Data Mining: Practical Machine Learning Tools and Techniques]],​ Fourth Edition.
Line 14: Line 14:
 == Software == == Software ==
  
 +In this course we will use Python, together with the Natural Language Toolkit (NLTK). It is assumed that you are either familiar with Python already, or, due to your excellent preparation in the Vassar Computer Science program, you have the ability to learn it quickly.
 You can use the computers in the Asprey Lab in the Computer Science Department, which have all of the required software already installed. If you want to use your own computer, you should install the following: You can use the computers in the Asprey Lab in the Computer Science Department, which have all of the required software already installed. If you want to use your own computer, you should install the following: