[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[patch] fix a warning for gcc 4.3 and an include



Hello Raman,

the following patch for the espeak server fixes a warning for gcc 4.3,
and fixes  the way speak_lib.h is included.  The include file is
installed in /usr/include/espeak/speak_lib.h here, and as far as I know,
that is the place where it gets installed by default.

Please let me know what you think about this patch.

Thanks much,

William

Index: tclespeak.cpp
===================================================================
--- tclespeak.cpp	(revision 6204)
+++ tclespeak.cpp	(working copy)
@@ -42,7 +42,7 @@
 #include <stdlib.h>
 #include <string>
 #include <assert.h>
-#include "speak_lib.h"
+#include <espeak/speak_lib.h>
 #ifndef ESPEAK_API_REVISION
 #define ESPEAK_API_REVISION 1
 #endif
@@ -556,7 +556,7 @@
       aDefaultLang = (char*)getenv("LANG");
       if (aDefaultLang == NULL)
 	{
-	  aDefaultLang = "en";
+	  aDefaultLang = (char *) "en";
 	}
     }
 


If you have questions about this archive or had problems using it, please send mail to:

priestdo@cs.vassar.edu No Soliciting!

Emacspeak List Archive | 2007 | 2006 | 2005 | 2004 | 2003 | 2002 | 2001 | 2000 | 1999 | 1998 | Pre 1998

Emacspeak Files | Emacspeak Blog | Search the archive