[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem with latest svn



Hi

I've sorted it.  I'd forgotten that to stop emacs crashing Orca when
running it under GTK I was running emacs with the following script,
(posted by someone on the Orca list):

#!/bin/sh
export NO_GAIL=1
export NO_AT_BRIDGE=1
/usr/bin/emacs $*

Removing this from my path resolved my problems.  I believe the
problem is that $* removes some quotes when passing the arguments, so
messing up the commandline  actually passed to emacs.  Maybe it should
be /usr/bin/emacs "$*", although I haven't tested it.  

Anyway, I'm sorry for bothering the list with this, and thank you to
everyone who gave suggestions.

Alastair

 


On Tue, Sep 01, 2009 at 08:56:03AM -0700, T.V. Raman wrote:
> So examining what you're seeing:
> 
> (relevant lines appended at the end)
> 
> Here's what the build rule is doing;
> it's echoing a comment to the file, then generating it.
> It's loading the file in the process which should be benign -- but
> perhaps not in your case --- we need to find out why.
> 
> But to isolate the problem, run this command and see if it succeeds --
> examine emacspeak-loaddefs.el before and after. Also, try the command
> after removing file emacspeak-loaddefs.el
> 
> 
> 
> emacs -batch -q -no-site-file -l ./emacspeak-autoload.el  -f
> emacspeak-auto-generate-autoloads
> 
> -- 
> 
> 
> On 8/30/09, Alastair Irving <alastair.irving@sjc.ox.ac.uk> wrote:
> > Hi All
> >
> > I've just updated to the latest subversion, (revision 6222).  However, when
> > I do make config I get the following output:
> >
> >
> > cd etc; make config  #SRC=/home/alastair/emacspeak
> > make[1]: Entering directory `/home/alastair/emacspeak/etc'
> > make[1]: Leaving directory `/home/alastair/emacspeak/etc'
> > cd lisp; make config
> > make[1]: Entering directory `/home/alastair/emacspeak/lisp'
> > echo ";;;Auto generated" > emacspeak-loaddefs.el
> > emacs -batch -q -no-site-file   -eval '(setq vc-handled-backends nil
> > byte-compile-warnings t)'  -l ./emacspeak-load-path.el  \
> > 	-l ./emacspeak-autoload.el  \
> > 	-f emacspeak-auto-generate-autoloads
> > End of file during parsing
> > make[1]: *** [emacspeak-loaddefs.el] Error 255
> > make[1]: Leaving directory `/home/alastair/emacspeak/lisp'
> > make: *** [config] Error 2
> >
> >
> > I haven't seen this before.  Is there a problem with the latest svn or
> > has something changed on my system?
> >
> > Many thanks
> >
> > Alastair Irving
> >
> >
> > -----------------------------------------------------------------------------
> > To unsubscribe from the emacspeak list or change your address on the
> > emacspeak list send mail to "emacspeak-request@cs.vassar.edu" with a
> > subject of "unsubscribe" or "help".
> >
> >

-----------------------------------------------------------------------------
To unsubscribe from the emacspeak list or change your address on the
emacspeak list send mail to "emacspeak-request@cs.vassar.edu" with a
subject of "unsubscribe" or "help".



If you have questions about this archive or had problems using it, please send mail to:

priestdo@cs.vassar.edu No Soliciting!

Emacspeak List Archive | 2007 | 2006 | 2005 | 2004 | 2003 | 2002 | 2001 | 2000 | 1999 | 1998 | Pre 1998

Emacspeak Files | Emacspeak Blog | Search the archive