[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

emacspeakwin installer - byte compiling



Thinking more about the thing with cl-proclaim. This message is
something that was coming and going during my attempts. Alastair
helped me to understand it.

> 1. I first tried to install it with my current version of Emacs,
> 24.2, but it didn't work.  It complained that cl-proclaim wasn't
> defined, I suspect that this is because of the change from cl to
> cl-lib in version 24.3 so bytecode compiled with 24.3 using these
> functions won't be backwards compatible.  Once I upgraded to Emacs
> 24.3 this problem was solved.

So it seems that byte-compiling during the installation would increase
portability. I don't want to force a very specific Emacs
version. Installer has access to Emacs. It could run compiling
commands.

Do you think it's worth doing?

Jarek

-----------------------------------------------------------------------------
To unsubscribe from the emacspeak list or change your address on the
emacspeak list send mail to "emacspeak-request@cs.vassar.edu" with a
subject of "unsubscribe" or "help".



If you have questions about this archive or had problems using it, please send mail to:

priestdo@cs.vassar.edu No Soliciting!

Emacspeak List Archive | 2010 | 2009 | 2008 | 2007 | 2006 | 2005 | 2004 | 2003 | 2002 | 2001 | 2000 | 1999 | 1998 | Pre 1998

Emacspeak Files | Emacspeak Blog | Search the archive