[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: outloud on rh8



Hi,
Thanks for the suggestion. I hadn't tried that one yet. I went through
both libibmeci50.so and tcleci.so and all the dependencies appear to be
in order with ldd. Some of them were symlinks, i checked also where they
were pointing as well and all of it checked out. I also checked my
libstdc++ libraries. I've got 3.2.7 libstdc++ and libstdc++, i've also
got the compat-libstdc++ and compat-libstdc++-devel libraries installed
as well.
	Keep the suggestions coming.
Thanks.
Dave.


On Sun, 2 Feb 2003 20:04:56 +1100 Tim Cross <tcross@rapttech.com.au>
writes:
> 
> Try doing a 
> 
> ldd
> /usr/share/emacs/site-lisp/emacspeak/servers/linux-outloud/tcleci.so
> and make sure all the shared library dependencies are
> satisfied. Viavoice is linked with an older libstdc++ library which
> may not be installed by default on newer distributions. If this 
> shows
> no errors, do the same with the viavoice libibmeci50.so and make 
> sure
> all its dependancies are satisfied. Don't bother trying to run
> emacspeak until you get a successful test with tcl
> /usr/share/emacs/site-lisp/emacspeak/servers/outloud as it will not
> work if this command does not work. 
> 
> Tim
> >>>>> "awesome-dave1" == awesome-dave1  <awesome-dave1@juno.com> 
> writes:
> 
>  awesome-dave1> Hello,
>  awesome-dave1> 	Does anyone have outloud running on rh8? 
> I've
>  awesome-dave1> 	got emacspeak 17.0
>  awesome-dave1> installed as well as the viavoice runtime and
>  awesome-dave1> sdk. When i run the command: tcl
>  awesome-dave1> /usr/share/emacs/site-lisp/emacspeak/servers/outloud
>  awesome-dave1> this is what i get:
> 
>  awesome-dave1> Error: couldn't load file
>  awesome-dave1> 
> "/usr/share/emacs/site-lisp/emacspeak/servers/linux-outloud/tcleci.so":
>  awesome-dave1> 
> /usr/share/emacs/site-lisp/emacspeak/servers/linux-outloud/tcleci.so:
>  awesome-dave1> undefined symbol: __gxx_personality_v0
>  awesome-dave1>     while executing
>  awesome-dave1> "load $tclTTS/tcleci.so"
>  awesome-dave1>     (file
>  awesome-dave1>     
> "/usr/share/emacs/site-lisp/emacspeak/servers/outloud"
>  awesome-dave1>     line
>  awesome-dave1> 290)
> 
>  awesome-dave1> I have installed tclx, and ran make in
>  awesome-dave1> 
> /usr/share/emacs/site-lisp/emacspeak/linux-servers/outloud
>  awesome-dave1> and that ran without any errors.
>  awesome-dave1> 	Any suggestions?
>  awesome-dave1> Thanks.  Dave.
> 
> 
>  awesome-dave1> 
> ________________________________________________________________
>  awesome-dave1> Sign Up for Juno Platinum Internet Access Today Only
>  awesome-dave1> $9.95 per month!  Visit www.juno.com
> 
>  awesome-dave1> 
>
-------------------------------------------------------------------------
----
>  awesome-dave1> To unsubscribe from the emacspeak list or change 
> your
>  awesome-dave1> address on the emacspeak list send mail to
>  awesome-dave1> "emacspeak-request@cs.vassar.edu" with a subject of
>  awesome-dave1> "unsubscribe" or "help"
> 
> 


________________________________________________________________
Sign Up for Juno Platinum Internet Access Today
Only $9.95 per month!
Visit www.juno.com

-----------------------------------------------------------------------------
To unsubscribe from the emacspeak list or change your address on the
emacspeak list send mail to "emacspeak-request@cs.vassar.edu" with a
subject of "unsubscribe" or "help"


Emacspeak Files | Subscribe | Unsubscribe | Search