[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

compatibility with emacs 20.



Jim,

I'm pretty sure emacspeak no longer supports versions of emacs earlier
than 21 due to the changes in voice-lock. As emacs 21 supported font
locking under the console, Raman removed his voice locking
infrastructure and now leverages off the font ock subsystem to achieve
voice locking. 

Tim
 
James R. Van Zandt writes:
 > 
 > Robert -
 > 
 > You write that you still use emacs20 frequently.  When I run emacspeak
 > 23.505 under emacs20, I get the message
 > 
 >   Symbol's function definition is void: puthash
 > 
 > but no voice output.  puthash is used in quite a few of the elisp
 > files, and I read in NEWS that puthash was added in emacs 21.1.  So:
 > 
 > Are you using a previous verson of emacspeak with emacs20?
 > 
 >            - Jim Van Zandt
 > 
 > -----------------------------------------------------------------------------
 > To unsubscribe from the emacspeak list or change your address on the
 > emacspeak list send mail to "emacspeak-request@cs.vassar.edu" with a
 > subject of "unsubscribe" or "help"
 > 

-----------------------------------------------------------------------------
To unsubscribe from the emacspeak list or change your address on the
emacspeak list send mail to "emacspeak-request@cs.vassar.edu" with a
subject of "unsubscribe" or "help"


Emacspeak Files | Subscribe | Unsubscribe | Search