[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

emacs-w3 error in css



I'm getting the following error trying to access an on-line journal
page 
Debugger entered--Lisp error: (range-error "round" -1.0e+INF)
  round(-1.0e+INF)
  css-expand-color("#FF0000\"} span.c3 {color: #003399")
  css-expand-value(color "#FF0000\"} span.c3 {color: #003399")
  css-parse-args(207 431)
  css-parse(nil " body {\n  background-color: #FFFFFF;\n  color: #000000;\n }\n div.c8 {text-align: center}\n span.c7 {color: white}\n span.c6 {color: white; font-family: ARIAL,HELVETICA; font-size: 64%}\n p.c5 {font-weight: bold}\n span.c4 {color: #FF0000\"}\n span.c3 {color: #003399; font-family: ARIAL,HELVETICA; font-size: 80%}\n h1.c2 {color: white; font-family: helvetica, arial; font-size: 207%}\n h1.c1 {color: white; font-family: helvetica, arial; font-size: 172%}" #<hash-table 'eql nil 50/70 0xa5fabb0>)
  w3-handle-style((data " body {\n  background-color: #FFFFFF;\n  color: #000000;\n }\n div.c8 {text-align: center}\n span.c7 {color: white}\n span.c6 {color: white; font-family: ARIAL,HELVETICA; font-size: 64%}\n p.c5 {font-weight: bold}\n span.c4 {color: #FF0000\"}\n span.c3 {color: #003399; font-family: ARIAL,HELVETICA; font-size: 80%}\n h1.c2 {color: white; font-family: helvetica, arial; font-size: 207%}\n h1.c1 {color: white; font-family: helvetica, arial; font-size: 172%}" type "text/css"))
  w3-display-node((*document nil ((html nil ...))))
  w3-draw-tree(((*document nil (...))))
  w3-prepare-buffer()
  ad-Orig-w3-fetch-callback("http://jgr-biogeosciences-submit.agu.org/cgi-bin/main.plex?form_type=display_review_form&j_id=600&ms_id=320646&ms_rev_no=0&ms_id_key=v09G9eAWSmpFVBjLDcxBQ&rev_p_id=30886&display_review_ms_splash=&is_challenge_ms=0")
  w3-fetch-callback("http://jgr-biogeosciences-submit.agu.org/cgi-bin/main.plex?form_type=display_review_form&j_id=600&ms_id=320646&ms_rev_no=0&ms_id_key=v09G9eAWSmpFVBjLDcxBQ&rev_p_id=30886&display_review_ms_splash=&is_challenge_ms=0")
  apply(w3-fetch-callback "http://jgr-biogeosciences-submit.agu.org/cgi-bin/main.plex?form_type=display_review_form&j_id=600&ms_id=320646&ms_rev_no=0&ms_id_key=v09G9eAWSmpFVBjLDcxBQ&rev_p_id=30886&display_review_ms_splash=&is_challenge_ms=0")
  url-http-activate-callback()
  url-http-end-of-document-sentinel(#<process jgr-biogeosciences-submit.agu.org> "connection broken by remote peer\n")

Now a bit of glaring at this suggests the problem is the following
span.c4 {color: #FF0000\"}\n
which looks like a malformed css declaration.  
The question is whether it's coming from my end, i.e some kind of
default  or whether I should complain to the page admin.  
Looking at the source of the page I don't see any declaration that
looks like this.  

I'm using emacs, emacspeak and w3 from cvs.

Anyone understand emacs-w3 stylesheet handling well enough to know
where the arguments for css-parse are coming from?
thanks in advance
Peter




-- 
Peter Rayner: LSCE/IPSL, Laboratoire CEA-CNRS-UVSQ
address: Bat. 701 LSCE - CEA de Saclay
Orme des Merisiers, 91191 Gif/Yvette
work: +33  (1) 69 08 88 11;	mobile: +33 (6) 75 46 56 52;	 fax: +33 (1) 69 08 77 16
mail-to: peter.rayner@cea.fr

-----------------------------------------------------------------------------
To unsubscribe from the emacspeak list or change your address on the
emacspeak list send mail to "emacspeak-request@cs.vassar.edu" with a
subject of "unsubscribe" or "help"


Emacspeak Files | Subscribe | Unsubscribe | Search