[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Emacspeak auditory icons



zkline@ writes:

> 	As a consequence, I was wondering if anybody could point out the 
> steps I need to take in order to get the auditory icons to work?  I've 
> set the program to /usr/bin/aplay, though on the main emacspeak 
> customization menu it says it's m-player.  

You might be looking at something different.  If you do:

M-x customize-group

then enter:

emacspeak

then search for:

Emacspeak Sounds group: Go to Group 

press enter on "Go to Group"

then search for:

Emacspeak Play Program: Hide Value /usr/bin/aplay
   State: STANDARD.

This is the sounds player setting.  On the second line it says
"standard".  This _should_ be the default on your system.  Please check
this setting to make sure that it is correct.  This is the first step in
getting you on the right track.

If that setting is correct, from a shell buffer run the command:

which aplay

and make sure the path is the same as the one in the setting.

If those two are correct, try the command:

C-e C-a

or

M-x emacspeak-toggle-auditory-icons

and see if this does anything.  

I have never used these on a permanent basis.  I have only turned them
on if I am working on an emacspeak module and need to make sure that
interactive functions work as I expect.  Therefore I am not sure how to
turn these on automatically.  I see that there is a variable called
emacspeak-use-auditory-icons but the documentation says not to set this
by hand.  This might only mean for individual buffers, instead you
should use the function I mentioned above.  Since this is a command, you
_should_ be able to put it in your .emacs file to be run at startup.
I'm sure if I am off-base here someone will let me know.  I did not look
at every option in customize but with my quick glance I did not see
anything in there that should be set.

> How do I specify the location of m-player, for instance?  Could you
> give me steps?  Thanks, Zack.

First, lets make sure that you really need to set that.

rdc
-- 
Robert D. Crawford                                      rdc1x@comcast.net

> I'm an idiot..  At least this [bug] took about 5 minutes to find..
Disquieting ...
		-- Gonzalo Tornaria in response to Linus Torvalds's

-----------------------------------------------------------------------------
To unsubscribe from the emacspeak list or change your address on the
emacspeak list send mail to "emacspeak-request@cs.vassar.edu" with a
subject of "unsubscribe" or "help"



If you have questions about this archive or had problems using it, please send mail to:

priestdo@cs.vassar.edu No Soliciting!

Emacspeak List Archive | 2007 | 2006 | 2005 | 2004 | 2003 | 2002 | 2001 | 2000 | 1999 | 1998 | Pre 1998

Emacspeak Files | Emacspeak Blog | Search the archive