[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: new user and troubles with espeak



Hello Robert,

I ran it as root and got the following error. I don't have tcl8.3 so I wonder what to do to modify it so it works with the later version of tclx.

libtool --mode=link g++ -O2 -I/usr/include/espeak -fPIC  -DPIC  -I/usr/include/tcl8.3 -g -o libtclespeak.so tclespeak.lo
-ltclx8.3 -L/usr/lib -lespeak  -shared
libtool: link: g++ -O2 -I/usr/include/espeak -fPIC -DPIC -I/usr/include/tcl8.3 -g -o libtclespeak.so .libs/tclespeak.o 
-ltclx8.3 -L/usr/lib -lespeak
/usr/bin/ld: cannot find -ltclx8.3
collect2: ld returned 1 exit status
make: *** [libtclespeak.so] Error 1


Alonzo
On 06/08/2009 01:05 PM, Robert D. Crawford wrote:
Alonzo Cuellar <mariachiac@aim.com> writes:

  
I change to the directory
/usr/share/emacs/site-lisp/emacspeak/servers/linux-espeak
and issue
make -f makefile.tcl83
and I get the following errors
    

[snip]

I think this might be your problem:

  
/usr/bin/ld: cannot open output file libtclespeak.so: Permission
denied
    

Were you building as root or as yourself?

rdc
  



If you have questions about this archive or had problems using it, please send mail to:

priestdo@cs.vassar.edu No Soliciting!

Emacspeak List Archive | 2007 | 2006 | 2005 | 2004 | 2003 | 2002 | 2001 | 2000 | 1999 | 1998 | Pre 1998

Emacspeak Files | Emacspeak Blog | Search the archive