[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Espeak Server Likes PulseAudio?



I'm not sure if this will help or not, but following some advice I found on the web (I think from Tim.) I recompiled eSpeak from source to have it use PA if it was present. I'm sure you could do the opposite and force it to use ALSA. Here are the notes I wrote up for myself. I hope they help.

**** Recompiling eSpeak to Use PulseAudio

Unfortunately, the last syllable spoken is always truncated making it unusable.

I fixed this by downloading the source code for eSpeak and compiling it for runtime, which uses PulseAudio if it's running and PortAudio otherwise.

I went to http://espeak.sourceforge.net/download.html and downloaded the file espeak-1.46.02-source.zip.

I had to install the library development packages for PulseAudio and PortAudio.

$ sudo apt-get install libpulse-dev libportaudio-dev

Now after unpacking the source code for eSpeak, I went into the source directory, espeak-1.46.02-source/src, and I made the following changes to the Makefile:

#DATADIR=/usr/share/espeak-data
DATADIR=/home/chaltain/Tools/share/espeak-data

#PREFIX=/usr
PREFIX=/home/chaltain/Tools

# 'runtime' uses pulseaudio if it is running, else uses portaudio
AUDIO = runtime
#AUDIO = portaudio

Now I run the commands:

$ make all
$ make install

This creates new eSpeak libraries and binaries, using the runtime option, and places them in my ~/Tools directory.

Now to start Emacspeak with eSpeak and these new libraries, I run the commands:

$ export LD_LIBRARY_PATH=/home/chaltain/Tools/lib
$ emacspeak -e

aNow Emacspeak comes up and I don't have the latency issues.

Note that I exported the variable LD_LIBRARY_PATH instead of running the following command:

$ sudo ldconfig /home/chaltain/Tools/lib

so that I'd only run emacspeak with this new library and not making the change globally, so as not to impact Orca if I did something wrong.

When using ldconfig, note you can use

$ ldconfig -p | grep espeak

to see which eSpeak library is being used.

On 03/28/2013 11:48 AM, Steve Holmes wrote:
Somehow, it seems like every time I launch emacspeak now and when I
test the espeak server from the emacspeak servers directory, it
appears to be launching pulse audio on my system and that in turn is
giving me all kinds of problems with speech losses and taking over my
ALSA devices.  This all began recently when I thought I would give
Pulse another look since I use gnome and want gnome sound support.
But after running into conflicts with Speakup and ALSA, I decided to
disable Pulse by commenting out the default.pa file but every time I
start up emacspeak now, I get some broken or garbled speech and all
ALSA speech such as from speakup is silent until I quit emacs.  Anyone
know what could be going on here?

I would love to just uninstall pulse entirely but other packages
require the dumb thing so can't remove it.  Any way to get emacspeak's
espeak server to use ALSA only and not be calling on pulseaudio?

-----------------------------------------------------------------------------
To unsubscribe from the emacspeak list or change your address on the
emacspeak list send mail to "emacspeak-request@cs.vassar.edu" with a
subject of "unsubscribe" or "help".


--
Christopher (CJ)
chaltain at Gmail

-----------------------------------------------------------------------------
To unsubscribe from the emacspeak list or change your address on the
emacspeak list send mail to "emacspeak-request@cs.vassar.edu" with a
subject of "unsubscribe" or "help".



If you have questions about this archive or had problems using it, please send mail to:

priestdo@cs.vassar.edu No Soliciting!

Emacspeak List Archive | 2010 | 2009 | 2008 | 2007 | 2006 | 2005 | 2004 | 2003 | 2002 | 2001 | 2000 | 1999 | 1998 | Pre 1998

Emacspeak Files | Emacspeak Blog | Search the archive