[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: dectalk giving invalid command parameter



OK, here is the patch -- another strange thing the .servers file
mentions several files beginning with ssh which are not in the
directory.  Also, the dtk-soft program doesn't send the offending
string at all.

313c313
<                 puts -nonewline  $tts(write) "\[:i r 1
_.]$text\[_.] "
---
>                 puts -nonewline  $tts(write) "\[:i r 1 ]$text\[_.] "

The first line of the dtk-exp is:

# $Id: dtk-exp,v 18.0 2003/04/29 21:21:15 raman Exp $

on Saturday 05/17/2003 James R. Van Zandt(jrv@vanzandt.mv.com) wrote
 > 
 > John -
 > 
 > I'm glad to hear you got it working.  I don't understand your
 > description, though.  In versions 12.0 through 18.0 of emacspeak,
 > "_." appears only in function speech_task, not in function t.  Maybe
 > yours got corrupted?  Could you post a patch showing what you changed?
 > 
 > 	  - Jim Van Zandt
 > 
 > 
 > >Cc: emacspeak@cs.vassar.edu
 > >From: John Covici <covici@ccs.covici.com>
 > >Date: Thu, 15 May 2003 16:55:55 -0400
 > >
 > >I finally did the trace and I discovered that my hardware Dectalk
 > >doesn't like the following sequence:
 > >
 > >[:i r 1 _.][:to 250 75][_.]
 > >
 > >When I took out the _. where it first appears in the function t of
 > >dtk-exp, my synth was happy, but I am wondering what is going on?
 > >

-- 
         John Covici
         covici@ccs.covici.com

-----------------------------------------------------------------------------
To unsubscribe from the emacspeak list or change your address on the
emacspeak list send mail to "emacspeak-request@cs.vassar.edu" with a
subject of "unsubscribe" or "help"


Emacspeak Files | Subscribe | Unsubscribe | Search