[Prev][Next][Index][Thread]

Re: w3-3.0.82 problem with emacspeak



"Greg E. Priest-Dorman" <priestdo@cs.vassar.edu> writes:

> Well, this morning I decided to put in the latest beta w3 mode.  I was
> running w3-3.0.60, and I just put in w3-3.0.82.
> 
> Now, when ever I try to move to the next link (w3-widget-forward) it
> moves forward, but I also beeps and gives the error, "Symbol's
> function definition is void: emacspeak-widget-at"
> 
> Is there a simple way to correct this?
> 
> Is this happening to other people?

  Try this patch.  It will be in 3.0.83

-Bill P.

*** w3-speak.el	1997/02/13 23:05:46	1.23
--- w3-speak.el	1997/04/12 22:19:42
***************
*** 75,87 ****
  (defadvice w3-widget-forward (after emacspeak pre act comp)
    (when (interactive-p)
      (emacspeak-auditory-icon 'large-movement)
!     (emacspeak-widget-summarize (emacspeak-widget-at  (point )))))
! 
  
  (defadvice w3-widget-backward (after emacspeak pre act comp)
    (when (interactive-p)
      (emacspeak-auditory-icon 'large-movement)
!     (emacspeak-widget-summarize (emacspeak-widget-at  (point )))))
  
  (defadvice w3-scroll-up (after emacspeak pre act comp)
    "Provide auditory feedback"
--- 75,86 ----
  (defadvice w3-widget-forward (after emacspeak pre act comp)
    (when (interactive-p)
      (emacspeak-auditory-icon 'large-movement)
!     (emacspeak-widget-summarize (widget-at  (point )))))
  
  (defadvice w3-widget-backward (after emacspeak pre act comp)
    (when (interactive-p)
      (emacspeak-auditory-icon 'large-movement)
!     (emacspeak-widget-summarize (widget-at  (point )))))
  
  (defadvice w3-scroll-up (after emacspeak pre act comp)
    "Provide auditory feedback"