[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: problems compiling the emacspeak server for ttsynth



I can't find tcl-8.3 for my distro.
----- Original Message ----- From: "T. V. Raman" <raman@users.sf.net>
To: <don@draikes.com>
Cc: <emacspeak@cs.vassar.edu>
Sent: Monday, October 29, 2007 6:07 PM
Subject: problems compiling the emacspeak server for ttsynth


Use tcl 8.3 with the makefile that has the tcl8.3 suffix

"Don" == Don Raikes <don@draikes.com> writes:
   Don> Hello, I am running oracle enterprise linux 5.0 kernel
   Don> 2.6.18-8, and have been trying to get emacspeak to work
   Don> on it.
Don> Don> I installed emacs 22.1 from teh gnu.org ftp site, and
   Don> checked out emacspeak from subversion.
Don> Don> I built emacspeak without a problem, and have gotten it
   Don> to work with espeak as well (thanks to a patch from
   Don> Lukas Loehrer).
Don> Don> Now I am having problems getting the emacspeak server
   Don> for ttsynth to compile.
Don> Don> I installed ttsynth last week, and I was able to compile
   Don> the ttsynth_say program with minimal problems and it
   Don> speaks just fine. ttsynth also works with gnome-speech
   Don> without a problem.
Don> Don> When I try to compile the ttsynth server for emacspeak,
   Don> I get the following error messages: libtool
   Don> --mode=compile g++ -g -O2 -fPIC -DPIC -pedantic -ansi
   Don> -Wall -c atcleci.cpp g++ -g -O2 -fPIC -DPIC -pedantic
   Don> -ansi -Wall -c atcleci.cpp -fPIC -DPIC -o
   Don> .libs/atcleci.o g++ -g -O2 -fPIC -DPIC -pedantic -ansi
   Don> -Wall -c atcleci.cpp -o atcleci.o >/dev/null 2>&1
   Don> libtool --mode=compile g++ -g -O2 -fPIC -DPIC -pedantic
   Don> -ansi -Wall -c langswitch.cpp g++ -g -O2 -fPIC -DPIC
   Don> -pedantic -ansi -Wall -c langswitch.cpp -fPIC -DPIC -o
   Don> .libs/langswitch.o langswitch.cpp: In function 'const
   Don> char* getAnnotation(Tcl_Interp*, int*)':
   Don> langswitch.cpp:172: error: invalid conversion from
   Don> 'const char*' to 'char*' make: *** [langswitch.lo] Error
   Don> 1
Don> Don> My gcc version is 4.1.1-58 and my tcl version is 8.4.13. Don> Don> Any help would be greatly appreciated.

--
Best Regards,
--raman

Email: raman@users.sf.net
WWW:    http://emacspeak.sf.net/raman/
AIM:    emacspeak       GTalk: tv.raman.tv@gmail.com
PGP:    http://emacspeak.sf.net/raman/raman-almaden.asc
Google: tv+raman IRC: irc://irc.freenode.net/#emacs


-----------------------------------------------------------------------------
To unsubscribe from the emacspeak list or change your address on the
emacspeak list send mail to "emacspeak-request@cs.vassar.edu" with a
subject of "unsubscribe" or "help"



If you have questions about this archive or had problems using it, please send mail to:

priestdo@cs.vassar.edu No Soliciting!

Emacspeak List Archive | 2007 | 2006 | 2005 | 2004 | 2003 | 2002 | 2001 | 2000 | 1999 | 1998 | Pre 1998

Emacspeak Files | Emacspeak Blog | Search the archive