[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: emacspeak for windows



Hi,

Clarification please:  Emacs 23.4 or 24.3?

Thanks.  I can't wait to get home and try this on my Windows laptop!  Tell me, will it work on 64 bit?

Major kudos,
Alex M

-----Original Message-----
From: Alastair Irving [mailto:alastair.irving@sjc.ox.ac.uk] 
Sent: Monday, October 07, 2013 3:11 PM
To: emacspeak@cs.vassar.edu
Subject: Re: emacspeak for windows

Hi

Very nice work, its great that someones finally done this.

I've got it working on my system after a few minor issues.

1. I first tried to install it with my current version of Emacs, 24.2, but it didn't work.  It complained that cl-proclaim wasn't defined, I suspect that this is because of the change from cl to cl-lib in version
24.3 so bytecode compiled with 24.3 using these functions won't be 
backwards compatible.   Once I upgraded to Emacs 24.3 this problem was 
solved.

2. It was now working but the speech quality was terrible, Espeak seemed to have developed a lisp.  I sorted it by upgrading my version of Espeak to the latest one.

It now all seems to be working perfectly.  It might be good to say in the docs that Emacs 24.3 is definitely required as well as which version of Espeak is needed.

Finally, it would be nice if the installer offered to make Desktop and Start menu shortcuts, presumably it would be very easy to implement.

Best wishes and thank you for all your work on this.

Alastair Irving














On 06/10/2013 19:04, Jarek Czekalski wrote:
> Hi readers
>
> After about a month of work I was finally able to prepare an official 
> release of Emacspeak for Windows.
>
> It works at my box, but I won't be surprised if you catch something, 
> that will need corrections. So I'm open for feedback.
>
> The Windows specific files will be hosted at Sourceforge, in a 
> separate project, emacspeakwin. In simplest case you download the 
> installer and launch it. For devs there is also src directory with all 
> the helper files that were needed to build the stuff.
>
> And finally, the link:
> https://sourceforge.net/projects/emacspeakwin/files
>
> To use it you will need Emacs 23.4 and eSpeak. Details in the installer.
>
> Cheers
> Jarek
>
> ----------------------------------------------------------------------
> -------
>
> To unsubscribe from the emacspeak list or change your address on the 
> emacspeak list send mail to "emacspeak-request@cs.vassar.edu" with a 
> subject of "unsubscribe" or "help".
>

-----------------------------------------------------------------------------
To unsubscribe from the emacspeak list or change your address on the emacspeak list send mail to "emacspeak-request@cs.vassar.edu" with a subject of "unsubscribe" or "help".


-----------------------------------------------------------------------------
To unsubscribe from the emacspeak list or change your address on the
emacspeak list send mail to "emacspeak-request@cs.vassar.edu" with a
subject of "unsubscribe" or "help".



If you have questions about this archive or had problems using it, please send mail to:

priestdo@cs.vassar.edu No Soliciting!

Emacspeak List Archive | 2010 | 2009 | 2008 | 2007 | 2006 | 2005 | 2004 | 2003 | 2002 | 2001 | 2000 | 1999 | 1998 | Pre 1998

Emacspeak Files | Emacspeak Blog | Search the archive