[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: W3 and Emacs21




Victor, 

A couple of things to look at -

1. Check out the known problems file in the etc directory of the
emacs21 distribution. It lists a number of packages which have
problems working with emacs 21 and in some cases provides patches
which can be applied.

2. With respect to w3. Yes, therre are some problems. You can get w3
to work with emacs 21, but its a bit buggy and some things don't work
properly. To get it to work at its best, you need to get the latest
cvs version of w3. I'm afraid I don't have the url with me at
present. I found it via a search through google though.

I've been using emacs 21 for the last few weeks and apart from the w3
problems and problems with info (for which I believe Raman has added a
hack in the later versions of emacspeak), it has been working very
nicely for me. However, as I said in an earlier post, most of the
enhancements for emacs 21 are of little benefit to blind and vision
impaired users. While there are some nice additions, most of these can
be added to emacs 20 anyway. I suppose the biggest change with emacs
21 is the ability to handle different fonts (not just fixed), provide
colors when running under the linux console and icon toolbars - all of
which may only offer minimal or no added functionality for many
emacspeak users. Considering w3 is currently a bit flakey, its
probably worth holding off for a while, unless your like me and just
can't wait to tinker with a new release. Just keep in mind that this
is a major version shift for emacs and consequently, there are likely
to be many packages which do not work as well (or at all), so be
prepared to either lose some functionality or stability. My personal
experience has been pretty good, but my current requirements are very
ell defined and I'm only using a minimum set of add on packages at
this stage (tramp, vm, records and some sql related
modes/enhancements). 

Tim
Victor Tsaran writes:
> Hello, listers!
> Do I understand it correctly that Emacs21 cannot be used in conjunction with W3-4.0.pre44? When I tried to install the two, I got errors that "w3-e21" cannot be loaded.
> In general, I like Emacs21 better, but as Raman reported, there are problems between Emacs21 and W3-4.0.pre46.
> Can you please clarify this for me?
> Best regards,
> Victor
> 
> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
> <HTML><HEAD>
> <META http-equiv=Content-Type content="text/html; charset=iso-8859-1">
> <META content="MSHTML 6.00.2600.0" name=GENERATOR>
> <STYLE></STYLE>
> </HEAD>
> <BODY bgColor=#ffffff>
> <DIV><FONT face=Arial size=2>Hello, listers!</FONT></DIV>
> <DIV><FONT face=Arial size=2>Do I understand it correctly that Emacs21 cannot be 
> used in conjunction with W3-4.0.pre44? When I tried to install the two, I got 
> errors that "w3-e21" cannot be loaded.</FONT></DIV>
> <DIV><FONT face=Arial size=2>In general, I like Emacs21 better, but as Raman 
> reported, there are problems between Emacs21 and W3-4.0.pre46.</FONT></DIV>
> <DIV><FONT face=Arial size=2>Can you please clarify this for me?</FONT></DIV>
> <DIV><FONT face=Arial size=2>Best regards,</FONT></DIV>
> <DIV><FONT face=Arial size=2>Victor</FONT></DIV>
> <DIV>&nbsp;</DIV></BODY></HTML>

-- 
Tim Cross
mailto: tcross@northnet.com.au
phone: +61 2 6772 5973
mobile: 0412 969193
------------------------------------------------------------------------

-----------------------------------------------------------------------------
To unsubscribe from the emacspeak list or change your address on the
emacspeak list send mail to "emacspeak-request@cs.vassar.edu" with a
subject of "unsubscribe" or "help"


Emacspeak Files | Subscribe | Unsubscribe | Search