[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: debian emacspeak 15 package




Yvonne,

I also had problems installing debian package with emacspeak 15. In my
case the source of problems was exactly that emacspeak initiated the
variable emacspeak-directory to contain path
/usr/share/emacs21/site-lisp/emacspeak/
which is by itself probably right, but then emacspeak calculated other
directories as being relative to this one. And that was already wrong
for debian installation. For example, because of wrong value in
emacspeak-sounds-directory I got the following message upon startup
and auditory icons not playing:

Theme /usr/share/emacs21/site-lisp/sounds/default-8k/ is missing its configuration file. 

(Note the incorrect path.)

To avoid this problem one might assign right values to all relevant
emacspeak-xxx-directory variables in the file
/etc/emacs/site-start.el.

Personally, I corrected these values directly in the emacspeak sources
because usually I run emacs with parameter --no-site-file when I work
as root.


>>>>> "YS" == Yvonne Smith <yvonne@thewatch.net> writes:

YS> Has anyone successfully installed the Debian emacspeak 15 package? I did
YS> this on a clean system, e.g. no previous versions of emacspeak
YS> installed, and got some truly strange errors. For a start, the xsl
YS> directory wasn't there at all, and w3 refused to work with some kind of
YS> outloud-style error, which I can't remember at the moment. Was this a
YS> weird problem on my system? Am I perhaps going mad?



Regards,
    Dimitri

-----------------------------------------------------------------------------
To unsubscribe from the emacspeak list or change your address on the
emacspeak list send mail to "emacspeak-request@cs.vassar.edu" with a
subject of "unsubscribe" or "help"