[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: CVS version of Emacspeak Still Breaks




To be honest, I've always doen the make config SRC=`pwd` as that is
whats in the Makefile on how to build it. I've never tried it without
doing so.

Tim

>>>>> "Steve" == Steve Holmes <steve@holmesgrown.com> writes:

 Steve> This all happened with a brand new CVS download on Friday
 Steve> morning; has something changed since then? When I did the make
 Steve> config, I had just completed the CVS checkout for the first
 Steve> time.  I had not specified any src directories as I didn't
 Steve> think I needed to.

 Steve> On Sun, Feb 01, 2004 at 12:43:20PM +1100, Tim Cross wrote:
 >>  Before doing the make config, try doing a make clean, then do
 >> 
 >> make config SRC=`pwd` make
 >> 
 >> If that doesn't work, totally wipe out your cvs-emacspeak
 >> directory and download the sources again. If you have made any
 >> changes to any of the lisp files in the distribution directory and
 >> then do a download, all the files may not have been updated as CVS
 >> may think they are later versions. Removing everything (or moving
 >> it sideways under a different root) will force a full download.
 >> 
 >> Tim
 >> 
 >> >>>>> "Steve" == Steve Holmes <steve@holmesgrown.com> writes:
 >> 
 Steve> I just pulled down the latest version of emacspeak yesterday
 Steve> and did a make config with no problems but when I did the make
 Steve> step, I got the following error and the build failed.  I then
 Steve> removed emacspeak-websearch.elc and dependencies from the
 Steve> Makefile and then the build finished successfully.  This rings
 Steve> similar to the problem with the prod 19.0 version.  -----
 Steve> Begin make.log ----- cd lisp; make
 Steve> SRC=/home/steve/cvs/emacspeak make[1]: Entering directory
 Steve> `/home/steve/cvs/emacspeak/lisp' emacs -batch -q -no-site-file
 Steve> -l /home/steve/cvs/emacspeak/lisp/emacspeak-load-path.el -l
 Steve> /home/steve/cvs/emacspeak/lisp/emacspeak-loaddefs.el -l
 Steve> /home/steve/cvs/emacspeak/lisp/emacspeak-cus-load.el -f
 Steve> batch-byte-compile emacspeak-websearch.el While compiling
 Steve> toplevel forms in file
 Steve> /home/steve/cvs/emacspeak/lisp/emacspeak-websearch.el: !!
 Steve> Symbol's value as variable is void ((w3-mode-map)) Done
 Steve> make[1]: *** [emacspeak-websearch.elc] Error 1 make[1]:
 Steve> Leaving directory `/home/steve/cvs/emacspeak/lisp' make: ***
 Steve> [emacspeak] Error 2 ----- End make.log -----
 >>
 Steve> -- HolmesGrown Solutions The best solutions for the best
 Steve> price!  http://ld.net/?holmesgrown
 >>
 Steve> -----------------------------------------------------------------------------
 Steve> To unsubscribe from the emacspeak list or change your address
 Steve> on the emacspeak list send mail to
 Steve> "emacspeak-request@cs.vassar.edu" with a subject of
 Steve> "unsubscribe" or "help"
 >>

 Steve> -- HolmesGrown Solutions The best solutions for the best
 Steve> price!  http://ld.net/?holmesgrown

-----------------------------------------------------------------------------
To unsubscribe from the emacspeak list or change your address on the
emacspeak list send mail to "emacspeak-request@cs.vassar.edu" with a
subject of "unsubscribe" or "help"