[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

emacspeak and auctex




I've noticed a problem with comments when using auctex to create latex
files with emacs 21.3 and emacspeak 19. 

When creating a latex document, if I put a comment in with % all
subsequent lines have their font-locking changed so that they are set
to the font-lock comment face. If I insert a control-l into the
document, then lines following the control-l are font-locked with the
correct face. 

I'm pretty sure this is a problem within emacspeak. Here is what I
have done to verify this -

1. run emacs -q to prevent my .emacs from being loaded. Note that I
   have a file called 10emacspeak.el in my /etc/emacs/site-start.d
   which starts emacspeak. The problems with comments in latex files
   still exist.

2. I then moved my 10emacspeak.el file out of my
   /etc/emacs/site-start.d directory and started emacs with emacs -q
   again. This time, no problems, latex comments are font-locked
   correctly.

3. I then ran emacs without the -q switch and latex files are font
   locked correctly with the coment lines in it. 

Now, to me this looks like the problem is within emacspeak (I'm
running version 19). It could also be a problem with some weird
interaction between emacspeak and other packages I have installed and
which are loaded from my site-start.d directory. 

What I would like to know is if anyone else has observed the same
thing. If others are running emacspeak 19 and not having a problem
with font-locking and comments when editing latex files with auctex,
I'd also like to hear from you. I'd like to know what other packages you
are loading and what distribution you are running. I'm running on
Debian sarge (aka testing). If I can get enough info from people who
are runing similar versions who are having problems and some who are
not, I might be able to determine which third party package is
causeing the problems and then work out how to fix it. Meanwhile, when
I have time, I will see if I can track anything down within emacspeak
itself. 

Note that I've observed this behavior on two different debian
boxes. The second system is a fresh install on a new system of debian
sarge with a minimal number of emacs packages from the sarge
distribution, which makes me think it more than likely is emacspeak. 

If anyone more familiar with the internal workings of emacspeak has
any idea why a control-l will stop the subsequent lines form being
incorrectly font-locked, let me know as this may narrow down the
possiblities and make it easier for me to possibly track down the
problem. 

Tim


-----------------------------------------------------------------------------
To unsubscribe from the emacspeak list or change your address on the
emacspeak list send mail to "emacspeak-request@cs.vassar.edu" with a
subject of "unsubscribe" or "help"