[Prev][Next][Index][Thread]

another w3 question



hi evryone,
I've been struggeling with w3 for quite a while now :).

I created the simlinks in /usr/share/emacs/site-lisp.
my emacspeak source is in /usr/local/emacspeak.

when compiling emacspeak-widget.elc, I get:

bash# make emacspeak-widget.elc
emacs -batch -q -no-site-file  -l `pwd`/emacspeak-load-path -f batch-byte-compile `pwd`/emacspeak-widget.el
Widget libraries not found, widget support may not work correctly.
While compiling toplevel forms in file /usr/local/emacspeak/emacspeak-widget.el:
  ** reference to free variable :emacspeak-help
  ** reference to free variable :parent
While compiling the end of the data:
  ** The following functions are not known to be defined: 
    define-widget-keywords, widget-get, widget-value, widget-put
Wrote /usr/local/emacspeak/emacspeak-widget.elc
Done
bash# 

I have tried almost evrything i can think of.  has anyone got any ideas as to whats going wrong.

if i use m-x load-library w3, i get:

Loading w3...
Loading w3-sysdp.el...
Loading w3-sysdp.el...done
Loading  w3-sysdp.el
ad-handle-definition: `w3-open-local' got redefined
ad-handle-definition: `w3-fetch' got redefined
ad-handle-definition: `w3' got redefined
Loading emacspeak-w3...
Cannot open load file: emacspeak-load-path


Hope I've given enough info.
bye for now 
Bart.

ps, can someone tell me how to load the keymap that is for the linux console and, just one more question.  How do i set the default global rate for the dectalk?