[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: emacs upgrade in debian



Apologies for the delay for this reply, please see below.

On Sat, Aug 15, 2009 at 09:36:13AM +1000, Tim Cross wrote:
> 
> If your emacspeak is quite old, you will need to update it to work with
> emacs 23. I'm not sure if thre is a current version of emacspeak as a

Ok built that fine from svn.

> You will then need to cd to the server/linux-espeak directory and build the
> espeak server by running make. Note that there has been some
> incompatibility with libtool in recent versions of ubuntu, so you may need
> to modify the makefile. However, try it out first and see if it builds. If
> it doesn't and you get link errors, let us know and I'll try to provide an
> updated Makefile. 

An updated makefile would be greatly appreciated.

Here is output from make:

libtool --mode=compile g++ -O2 -I/usr/include/espeak -fPIC  -DPIC -pedantic  -Wall -I/usr/include/tcl8.4 -c tclespeak.cpp
libtool: compile:  g++ -O2 -I/usr/include/espeak -fPIC -DPIC -pedantic -Wall -I/usr/include/tcl8.4 -c tclespeak.cpp  -fPIC -DPIC -o .libs/tclespeak.o
In file included from tclespeak.cpp:40:
/usr/include/tcl8.4/tcl.h:416: error: ISO C++ 1998 does not support ‘long long’
/usr/include/tcl8.4/tcl.h:417: error: ISO C++ 1998 does not support ‘long long’
tclespeak.cpp: In function ‘void initLanguage(Tcl_Interp*)’:
tclespeak.cpp:559: warning: deprecated conversion from string constant to ‘char*’
make: *** [tclespeak.lo] Error 1


Thanks very much,
Dan.

Attachment: signature.asc
Description: Digital signature



If you have questions about this archive or had problems using it, please send mail to:

priestdo@cs.vassar.edu No Soliciting!

Emacspeak List Archive | 2007 | 2006 | 2005 | 2004 | 2003 | 2002 | 2001 | 2000 | 1999 | 1998 | Pre 1998

Emacspeak Files | Emacspeak Blog | Search the archive