[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: error with emacspeak 14.0 under rh7.1



I never knew precisely what lesstif added to ViaVoice, so I appreciate
your note. It rather inclines me to remove lesstif, even.

PS: The rpm behavior of reporting missing dependencies works as you say on
my system and on every RH system I've worked on, come to think of it.

On Sun, 17 Jun 2001 tcross@northnet.com.au wrote:

>
> With rpm based systems, if the rpm won't install because of missing
> dependencies, it should report a list of dependencies which need to be
> satisfied before you can install.
>
> While it is true the rpm version expects the ViaVoice rpms to be
> installed before it will allow you to install emacspeak, you can avoid
> this. If you don't want to use ViaVoice, you can install the emacspeak
> rpm using the --nodeps switch i.e.
>
> rpm --nodeps -i emacspeak-14.0-1.noarch.rpm
>
> Also note, you can safely install the viavoice without the lesstif
> libraries by using the --nodeps switch as well. The ViaVoice rpm only
> needs the lesstif libraries if you want to run the gui based
> demonstration. You don't need this as there is a command line
> demonstration available which you can use to test viaVoice and
> viaVoice will run fine without the lesstif libraries when you want to
> use it with emacspeak.
>
> I think its always a good idea to try installing an rpm without the
> nodeps switch first and if it fails look at the dependencies which
> failed and then make a decision on how important those dependencies
> are. I know this can be difficult if you don't know much about linux
> or emacspeak. However, its better to do it this way rather than just
> using the nodeps switch without first checking as there may be other
> dependencies (like tclx etc) which you must have.
> Tim
> Janina Sajka writes:
> > Something on which Emacspeak is dependent is missing. Have you installed
> > ViaVoice? The rpm installation doesn't like it if you haven't, as I
> > recall. And, to install that, you'll need to install the lesstif
> > libraries, etc.
> >  On Sat, 16 Jun 2001 awesome-dave1@juno.com wrote:
> >
> > > Hello,
> > > 	Has anyone got emacspeak 14.0 working under rh7.1? I'm getting the
> > > error:
> > > error: emacspeak-14.0-1.noarch.rpm can not be installed.
> > > 	I've got tcl, tk, and tclx, and lesstif installed as I've done in the
> > > past for 12, but I've never seen this error before.
> > > 	Any ideas?
> > > Thanks.
> > > Dave.
> > >
> > > Visit my web site at:
> > > http://www.davemehler.com
> > >
> > > ________________________________________________________________
> > > GET INTERNET ACCESS FROM JUNO!
> > > Juno offers FREE or PREMIUM Internet access for less!
> > > Join Juno today!  For your FREE software, visit:
> > > http://dl.www.juno.com/get/tagj.
> > >
> > > -----------------------------------------------------------------------------
> > > To unsubscribe from the emacspeak list or change your address on the
> > > emacspeak list send mail to "emacspeak-request@cs.vassar.edu" with a
> > > subject of "unsubscribe" or "help"
> > >
> >
> > -----------------------------------------------------------------------------
> > To unsubscribe from the emacspeak list or change your address on the
> > emacspeak list send mail to "emacspeak-request@cs.vassar.edu" with a
> > subject of "unsubscribe" or "help"
>
>

-----------------------------------------------------------------------------
To unsubscribe from the emacspeak list or change your address on the
emacspeak list send mail to "emacspeak-request@cs.vassar.edu" with a
subject of "unsubscribe" or "help"


Emacspeak Files | Subscribe | Unsubscribe | Search